Dieses Thema enthält 9 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Robert vor 1 Woche, 5 Tagen.

Rabattanzeige bei variablem Produkt

  • Hallo zusammen,
    wahrscheinlich ist es ein Anfänger-Fehler, aber wie bekomme ich bei variablen Produkten (2 Variationen eine zu 7€ eine zu 10€) in der Shopübersicht den Rabatt-Icon weg? Irgendwie meint WooCommerce wohl, das wäre ein Rabatt, obwohl es doch unterschiedliche Varianten sind…

    Vielen Dank im Voraus!

    Dateianhänge:
    You must be logged in to view attached files.

    Hast du bei der €7 Variante einen Angebotspreis angegeben? Der ist direkt neben dem Feld für den regulären Preis.

    Nee, das hatte ich mir auch schon überlegt…aber steht alles unterm regulären Preis…

    Dateianhänge:
    You must be logged in to view attached files.

    Poste bitte mal einen Link zu deinem Shop, dann könnte ich mir das direkt ansehen.

    Die Ursache dafür kann ich leider auch nicht ganz nachvollziehen.
    Es ist zumindest der „Sale Badge“, der bei Aktionspreisen eingeblendet wird.

    Versuche das nachfolgende CSS unter „Design -> Customizer -> zusätzliches CSS“ einzusetzen. Damit kannst du zumindest erstmal die -30% bei diesem Produkt ausblenden, bis du die Ursache dafür gefunden hast.

    Super das ist schonmal eine gute Lösung! Vielen Dank.
    Ich kann es mir wie gesagt auch nicht erklären.
    Ich benutze ein Theme von future-themes („TheArtist“) als Childtheme. Kann es vielleicht damit zusammenhängen, dass die Templates nicht mehr alle aktuell sind (siehe Screenshot)?

    Dateianhänge:
    You must be logged in to view attached files.

    Das könnte eine Ursache sein, die archive-product.php steuert die Seite, wo der Sale Badge zu sehen war.

    Du kannst testweise folgendes versuchen,
    – lösche das CSS, damit der Badge wieder sichtbar wird
    – suche über FTP die archive-product.php im Parent Theme und bennene sie um (z.B. in archive-product-old.php)

    Danach müsste die Standard archive-product.php von Woocommerce einspringen. Wenn der Sale Badge dann weg ist, liegt’s an der veralteten Template Datei.

    Habe es sowohl beim Parent als auch beim Child Theme mal umbenannt – aber das Badge bleibt leider sichtbar…

    Hmm, im Moment habe ich leider keine weiteren Ideen, woran das liegen könnte.