Dieses Thema enthält 12 Antworten und 8 Teilnehmer. Es wurde zuletzt aktualisiert von  SK vor 2 Monate, 2 Wochen.

Versandkostenpauschale sichtbar bei kostenlosem Versand

  • Hallo liebe Woo Community

    Ich habe einen Onlineshop recht neu erstellt und habe jetzt ein Problem bei der Anzeige der Versandkosten:

    Ab einer gewissen Anzahl bestellter Produkte wird der Versand kostenlos.
    Hierfür ist bereits in den Einstellungen der Versandzonen der kostenlose Versand ab einer gewissen Summe aktiviert. Dieser wird auch aktiv, wenn in dem Onlineshop die Bestellsumme erreicht ist.

    Soweit funktioniert alles, jedoch ist die Versandkostenpauschale immer noch sichtbar und zur Auswahl zu verfügung.

    Ich habe alles ausprobiert, auch mit dem Code X*[qyt] oder X*[cost] die Versandkostenpauschale nicht mehr aktiv erscheinen zu lasssen, jedoch erfolglos.

    Ich bitte um Lösungsvorschläge für die dieses Problem

    Danke im Voraus schonmal

    Der Frage hänge ich mich mal an. Bei mir zeigt er nichtmal die Versandkostenfreie Lieferung an. Gestern als ich die „alte“ Versandkostenfreie Lieferung noch aktiviert hatte sah es bei mir genau so aus wie bei dir. Nun habe ich die „alte“ deaktiviert und die versandkostenfreie Lieferung wird gar nicht mehr gezeigt, auch nicht wenn der Kunde über die eingestellte Summe kommt.

    „Manchmal ist Fortschritt auch ein Rückschritt“

    Hi,
    @tim: das nervt mich auch. Letztens hat ein Kunde den Mindestbestellwert für Kostenlosen Versand erreicht, aber trotzdem Versandkosten bezahlt, weil er den Kostenlosen Versand nicht angeklickt hatte. Das sollte eigentlich automatisch passieren, und die Pauschale nicht mehr angezeigt werden.
    @chiara: habe heute auch auf die neuen Versandzonen gewechsel. Funktioniert gut. Ist weder fortschritt noch rückschritt. Du musst bei den Versandarten auch den Kostenlosen Versand hinzufügen

    Gruß Joe

    Hi Leute!

    Hatte auch das Problem. Ich habe es so gelöst, dass ich bei den Versandarten die Reihenfolge so gesetzt habe, dass die „kostenlose Lieferung“ zuerst in der Liste angeführt wird. Das hat zur folge, dass, wenn der Mindestbestellwert (oder Gutschein) zum tragen kommt, der erste Eintrag im Warenkorb ausgewählt wird -> d.h. in diesem Falle dann die „kostenlose Lieferung“

    Hoffe, der Input hat Euch geholfen.

    SG
    Alex

    Das sieht auch ganz nach meinem Problem aus: https://wooexperten.de/thema/versandkostenoption-wird-doppelt-angezeigt/

    WIR BENÖTIGEN HILFEEEE!!!!

    Das ist mit WooCommerce Boardmitteln nicht zu lösen, also nicht mit einem Klick. Um alle Versandarten auszublenden wenn kostenloser Versand zur Verfügung steht, kann man folgende Funktion in die functions.php eine Childthemes legen:

    add_filter( ‚woocommerce_package_rates‘, ‚mmx_hide_shipping_if_free‘, 100 );
    function mmx_hide_shipping_if_free( $rates ) {
    $free = array();
    foreach ( $rates as $rate_id => $rate ) {
    if ( ‚free_shipping‘ === $rate->method_id ) {
    $free[ $rate_id ] = $rate;
    }
    }
    if( ! empty( $free ) ){
    $rates = $free;
    }
    return $rates;
    }

    Das schießt bei mir leider alles aus! Ich kann weder das Frontend noch das Backend mehr sehen, es bleibt bei beiden ein weißer Bildschirm.

    Alle Anführungszeichen müssen einfache Hochkomma sein (shift taste + #)

    In diesem Forum kann man Quellcode leider nicht vernünftig posten. Für die Anführungszeichen braucht man die code oder pre tags

    verwendet man aber die pre oder code tags werden die größer und kleiner als Zeichen zerstört

    <>

    Es wäre nützlich wenn sich die Admins einmal darum kümmern würden

    • Diese Antwort wurde geändert vor 1 Jahr von  mensmaximus. Grund: Test mit pre statt code
    • Diese Antwort wurde geändert vor 1 Jahr von  mensmaximus.
    • Diese Antwort wurde geändert vor 1 Jahr von  mensmaximus. Grund: keine vernünftige Formatierung möglich

    Hallo mensmaximus!

    Perfekt. Sehr schön. Genau das. Bin sehr zufrieden.
    Interessanterweise wurde bei mir beim ersten Mal auch ein Hochkomma angezeigt als ich den Code eingefügt habe, deswegen ist es mir nicht aufgefallen. ABER…es gibt wohl noch ein Hochkomma, und zwar ein kursives. Das unterscheidet sich dann vom regulären Hochkomma.

    Noch ein Frage:
    Ich habe weiter oben einen Link zu einem anderen Beitrag von mir eingefügt. Da geht es um etwas ganz Ähnliches. Hast du dafür auch eine Lösung?

    Hallo Ihr Lieben,
    Ich bin blutiger Neuling,
    Ich habe begriffen das ich den Codeschnipsel in die Datei kopieren muss und anpassen muss.
    Aber wo genau muss ich es platzieren? Oder ist das Egal?

    Liebe Grüße

    @mischky: „in die functions.php eine Childthemes“. Einfach ans Ende.

    Vielen Dank, hat alles sehr gut geklappt,

    Hallo,

    vielen Dank für die Hilfe. Dies hat sehr gut funktioniert. Wenn ich allerdings bei einem Produkt einen Versandpreis zuordne und dieses in den Warenkorb lege, werden mir wieder beide Versandoptionen eingeblendet. Vorne: Kostenloser Versand, darunter: Versandkostenpauschale.

    Ist es möglich, dass wenn ein Produkt mit hinterlegten Versandkosten definiert wurde, und im Warenkorb beim checkout > dann auch bei Versand die „Versandklasse mit Kosten“ dargestellt wird und die Option „kostenloser Versand“ entfällt?

    Viele Grüße

Schlagwörter: